Skip to end of metadata
Go to start of metadata

The Production Utility is a tool that merges SuperCROSS tables with SuperCROSS recodes to produce new tables. It works in conjunction with the batch processing feature: the Production Utility merges tables with recodes and then passes them to the batch processor to generate the output formats.

To access the Production Utility, select File > Production Utility in SuperCROSS. The Production Utility window displays:

Step 1 - Set Up Batch Processing

Before you can start using the Production Utility, follow the steps to set up SuperCROSS to use batch processing mode.

Step 2 - Select your Directories

The next step is to select the directories where your source tables and recodes are located, and the directory to save the resulting tables.

  • The Production Utility loads the SuperCROSS table files (either .scs or .txd format) from one directory and the SuperCROSS recode files (either .rcd, .scs or .txt format) from a different directory.
  • Its output directory must be the batch processing input directory (the Input directory located in the interchange directory you created for batch processing).

To select the directories:

  1. Click Preferences.

    The Preferences window displays.

  2. Use the Browse buttons to select the directories for each type of file:

    TableSuperCROSS table files for processing, in either .scs or .txd format.
    RecodeRecode files for use in the merge, in either .rcd, .scs or .txt format.
    Output

    The directory to store the merged output. Set this to the Input directory located in the interchange directory you created for batch processing.

    If you select the Auto Overwrite check box, the Production Utility will automatically overwrite any existing files in the output directory that have the same name as a new output table. If you do not select this option then new output tables with the same name will not be saved.

    Error

    The directory to store the Production Utility log file and any table files with errors.

    If you select the Auto Overwrite check box, the Production Utility will automatically overwrite any existing files in the output directory that have the same name as a new error table. If you do not select this option then new error tables with the same name will not be saved.

  3. (Optionally) Select the Set As Default check box if you want to save the settings for the next time you use Production Utility. Your directory details will be stored in the prodmod.ini configuration file.
  4. When you have finished selecting the directories, click OK.

Step 3 - Select your Output Formats

  1. Click Output Format.
  2. Select all of the formats you want to create.
  3. Click OK.

Step 3 - Select your Tables

  1. Click Select Tables to choose the tables you want to process. The Select Tables window displays a list of all the table files in the table directory you selected in the previous step.

    If you do not see your tables in the list, use the File Extension drop-down list to choose between .scs and .txd format:

  2. Select the tables you want to process from the Tables list, and click Select to move them to the Selected Tables list:

  3. You can also use the Select All button to move all the tables across to the Selected Tables list, and the Remove and Remove All buttons to move tables back out of the Selected Tables list.
  4. When you have finished selecting tables, click OK.

Step 3 - Select your Recodes

  1. Click Select Recodes to choose the recode files you want to use during processing. The Select Recodes window displays a list of all the recode files in the recode directory you selected in the first step.

    If you do not see your tables in the list, use the File Extension drop-down list to choose between .scs and .txd format:

  2. Select the recodes you want to use from the Recodes list, and click Select to move them to the Selected Recodes list:

  3. You can also use the Select All button to move all the recodes across to the Selected Recodes list, and the Remove and Remove All buttons to move recodes back out of the Selected Recodes list.
  4. Choose the Merge Method you want to use:

    AddThe fields contained in the recode file will be added to the table if they are not already present. When you select this option, you also need to choose the Axis Position where you want to add the recoded fields.
    ReplaceThe fields contained in the recode file will replace the same fields if they already exist in the table.
    Add & ReplaceThe fields contained in the recode file will be added to the table if they are not already present or will replace the same fields if they already exist in the table. When you select this option, you also need to choose the Axis Position to add any new fields.
  5. Choose the Axis Position you want to use to add any new fields. This option only applies if you set the Merge Method to either Add or Add & Replace:

    RowNew recoded fields will be added above all other fields in the row axis.
    ColumnNew recoded fields will be added above all other fields in the column axis.
    WaferNew recoded fields will be added above all other fields in the wafer axis.
    Evenly Distribute

    New recoded fields will be evenly distributed between the wafer, row and column axes, starting with the wafer axis.

    This option is designed for situations (such as creating a .srd file) where it does not matter which axis the recodes are added to.

  6. When you have finished selecting recodes, click OK.

Step 4 - Run the Merge Operation

When you have finished selecting the options, enter a name for your job in the Run Name field (this will be displayed in the log file), and then click Merge.

The Merge window displays:

Choose one of the following processing methods:

[1] Table + [1] Recode = [1] Table

Each table will be combined with its corresponding recode file to create a single table output file.

The recode file and the table file must both be named with the same filename (but with different file extensions). Only the tables need to be selected; Production Utility will find the recode files with the same file names in the recode directory and merge them with the table.

[1] Table + [n] Recodes = [1] TableEach table will be combined with multiple recode files (as many as are selected under Select Recodes) to create a single table output file.
[1] Table + [n] Recodes = [n] TablesEach table will be combined with multiple recode files (as many as are selected under Select Recodes) to create multiple table output files.

When you have selected the processing method, click OK to run the job:

  1. Production Utility will process your tables and generate an SCS output file in the interchange Input directory.
  2. The batch processing functionality will then pick up this file on its next run.
  3. When the batch processing completes, your chosen output formats will be saved to the interchange Output directory.

If there are any errors, they will be recorded in the log file, which will be written to your selected error directory.

  • No labels