Skip to end of metadata
Go to start of metadata

If you are distributing SuperCROSS to your users either via the network or by providing an installer on CD, you may wish to customise the standard installer so that it includes your own preferred settings and local databases.

This section describes how to customise the SuperCROSS installer for distribution.

Step 1 - Extract the Installation Files

The first step is to unzip the SuperCROSS installation files to a location on your local hard disk so that they can be modified.

The file structure will be similar to the following:

Step 2 - Apply Custom Configuration

The next step is to apply your customisations by editing the SuperCROSS configuration files. The main file you will need to edit is the product.ini configuration file. This is located in the product directory, and controls the installation process.

Following are some typical customisations:

Preconfigure the License Key

To preconfigure your SuperCROSS installation so that users do not need to enter the license key during the install, add your key to the [Preset] section. For example:

[Preset]
string=ABCDEFGHIJKLMNOPQRSTUVWXY
Add SXV4 Databases

To add your own SXV4 files so that they are automatically installed with SuperCROSS, do the following for each SXV4:

  1. Copy the SXV4 and any additional files that it requires to a location within the unzipped SuperCROSS installation files. Additional files includes anything that needs to be installed in the same directory as the SXV4, such as metadata files, weightings, confidentiality, mapping, predefined TXDs and default recodes.

    You can save your databases anywhere within the installation files, but to make it easier to manage, you are recommended to use the databases directory. You may wish to create a subdirectory for each individual SXV4.

  2. Edit the [1 Databases] section of the product.ini file to include the ID and path for each of your new databases:

    [1 Databases]
    <database_id>=<relative_path>

    Where <database_id> is the filename of the SXV4 (without the .sxv4 extension) and <relative_path> is the path to the directory containing the SXV4 relative to the location of setup.exe. For example, if you have added an SXV4 file called MyCustomDB.sxv4 to a directory called CustomDB with the databases directory, you need to add the following to [1 Databases]:

    MyCustomDB=\databases\CustomDB\
  3. Add the file size of your SXV4 (in bytes) to the [Database Sizes] section of product.ini. You can find out the size in bytes by right-clicking the SXV4 file and selecting Properties:

    [Database Sizes]
    <database_id>=<size_in_bytes>

    For example:

    MyCustomDB=35000281
  4. Add the display name of the SXV4 to the [Database Names] section of product.ini. The display name is the name that you want to appear in the SuperCROSS Catalogue window:

    [Database Names]
    <display_name>=<database_id>

    For example:

    My Custom Data=MyCustomDB
  5. Add your database to the [Catalogue] section of product.ini and specify a folder name. Your SXV4 files will be available inside this folder within the Local Access section of the Catalogue window.

    [Catalogue]
    <display name>=<folder>

    For example:

    My Custom Data=Example Folder
  6. (Optional). If the database uses mapping, add an entry to the [Mapdata Databases] section:

    [Mapdata Databases]
    <display_name>=true

    For example:

    My Custom Data=true
Customise the SuperCROSS Application Name

Edit the [General] section of product.ini to change the names that are used when SuperCROSS is installed.

For example:

Application Name=Data Tabulation Tool
Setup Name=Data Tab Tool Setup
Folder Name=SuperSTAR\Products
Start Name=SuperCROSS
Organisation=My Organisation Name
Remove the Default STR Databases

If you do not want to bundle the sample databases (Retail Banking and People), then you can remove these from the installer:

  1. Delete the files from the installer databases directory.
  2. Remove all references to them from the product.ini file. Make sure you remove them from all the sections (including the catalogue, map data, database names and databases sizes).
Change the Installer Splash Screen

The splash screen displays when the installer first starts. To replace the default branding with your own splash screen, replace the file setup.bmp with your own image. Your replacement image must be:

  • Windows Bitmap format.
  • 480 x 369 pixels.
  • Less than 256 colours.
Change the Installer Information Screens

During the installation process, there are two screens that display showing information about the product. To replace the default branding with your own images, replace the files bbrd1.bmp and bbrd2.bmp in the product directory. Your replacement images must be:

  • Windows Bitmap format.
  • 498 x 282 pixels.
  • Less than 256 colours.
Replace the User Guide

The user guide is stored in product\Help\SuperCROSS\user_guide. You can replace the supplied HTML files with your own user guide content by replacing the files in this directory.

The index to your user guide must be named index.html.

Bundle Additional FilesIf you need to bundle additional files with the installation, such as product guides and other documentation, copy these to the product\User Guides directory. Any files in this directory will be copied to the User Guides directory in the SuperCROSS program files.

Support Email Address

Edit the super.ini configuration file (located in the product directory) to customise the support email address that is linked from the Help > E-mail Support menu option.

Contact and Copyright in DownloadsEdit the super.ini configuration file to change the contact details and copyright statements that are included in download files. You will typically want to edit the HomeLinkEmail and Copyright settings for both HTML and Excel downloads.
Default SuperCROSS settings

If there are any other default SuperCROSS settings you want to change, edit the configuration files. For example, you may want to change settings in the cross.ini configuration file and the super.ini file. Both of these are located in the product directory of the installation files.

Step 3 - Test the Installer and Distribute

Once you have finished making changes, test your installer locally.

When you are happy you can either burn the installer files to CD or create a ZIP file for distribution.

  • No labels