This is the documentation for SuperSTAR 9.8

SuperSTAR 9.9 is now available.
View this page in the SuperSTAR 9.9 documentation or visit the SuperSTAR 9.9 documentation home.

Skip to end of metadata
Go to start of metadata

This section defines the hardware and software requirements for the SuperSTAR suite of products.

This information is subject to change. Please contact customer support if you wish to confirm specific details.

Support Levels

The following table defines four "support levels". These support levels are used throughout the compatibility tables in this section.

Support LevelWill SuperSTAR Work?Bug Reports Accepted?
Not CompatibleNoKnown to be incompatible.No
Not SupportedUnknownHas not been tested by STR.No
CompatibleYesSupported but is not actively tested by STR.Yes
Actively TestedYesSupported and actively tested.Yes

Hardware and Operating System Compatibility

Server Components

 32/64 bitMinimum
Service Pack
SuperSERVERSuperADMINSuperSERVICE ManagerProduction System
Windows Server 200864SP2CompatibleCompatibleCompatibleCompatible
Windows Server 2008 R264SP1Actively TestedActively TestedActively TestedActively Tested
Windows Server 201264 CompatibleCompatibleCompatibleCompatible
Windows Server 2012 R264 Actively TestedActively TestedCompatibleCompatible
OpenSUSE 12 (x86-64)6412.3Actively TestedActively TestedNot CompatibleCompatible
RHEL 764 CompatibleCompatibleNot CompatibleCompatible
Other Linux (x86-64)64 CompatibleCompatibleNot CompatibleCompatible
SUSE Linux (Platform z)64 Not SupportedNot SupportedNot SupportedNot Supported
The metadata utilities (supplied with SuperADMIN) are not available for Z Linux.

Web Server Support

 SuperVIEWSuperWEB2Open Data APIJob Queue ManagerSDMX Web Services
Apache Tomcat 6.0.xCompatibleNot CompatibleNot CompatibleNot CompatibleNot Compatible
Apache Tomcat 7.0.xActively Tested

Compatible. Actively Tested with Tomcat versions 7.0.57 and 7.0.65.

Not Compatible with Tomcat version 7.0.59.

Compatible. Actively Tested with Tomcat versions 7.0.57 and 7.0.65.

Tomcat version 7.0.41 or above is required for CORS support.

Compatible. Actively Tested with Tomcat version 7.0.57.Not Supported
IBM WebSphere 7.0.xNot SupportedNot SupportedNot SupportedNot SupportedNot Compatible
IBM WebSphere 8.5Not SupportedNot SupportedNot SupportedNot SupportedNot Compatible

Java Requirements

 SuperVIEWSuperWEB2SuperADMINSuperCHANNELSDMX Web Services
Oracle Java SE 6Not CompatibleNot CompatibleNot CompatibleNot CompatibleNot Compatible
Oracle Java SE 7Actively Tested

Not Compatible

Not Supported on Java version 7.0.55.

Not CompatibleNot CompatibleCompatible
Oracle Java SE 8Not Supported

Actively Tested

Actively Tested

Actively Tested

Not Supported
IBM Java SE 6Not CompatibleNot CompatibleNot CompatibleNot CompatibleNot Compatible
IBM Java SE 7Not SupportedNot CompatibleNot CompatibleNot SupportedNot Compatible
IBM Java SE 8Not SupportedActively TestedCompatibleNot SupportedNot Compatible

Installed Client Applications

 32/64 bit?Minimum
Service Pack
SuperCROSSSuperCHANNEL GUISuperCHANNEL SNU
Windows Vista32 and 64SP2CompatibleCompatibleCompatible
Windows 732 and 64SP1Actively TestedActively TestedCompatible
Windows 832 and 64 Actively TestedCompatibleCompatible
Windows 8.132 and 64 Actively TestedActively TestedActively Tested
Windows 10 Pro64 Actively TestedCompatibleCompatible
Windows Server 200864SP2CompatibleCompatibleCompatible
Windows Server 2008 R264SP1Actively TestedActively TestedActively Tested
Windows Server 201264 CompatibleCompatibleCompatible
Windows Server 2012 R264 Actively TestedActively TestedActively Tested
OpenSUSE 12 (x86-64)6412.3Not CompatibleNot CompatibleActively Tested
RHEL 764 Not CompatibleNot CompatibleCompatible
Other Linux (x86-64)64 Not CompatibleNot CompatibleCompatible
SUSE Linux (Platform z)64 Not CompatibleNot CompatibleNot Compatible

SuperCROSS requires the .NET Framework (the installer will install this automatically if necessary).

Web Applications

 SuperVIEWSuperWEB2
Chrome - Latest ReleaseActively TestedActively Tested
Firefox - Latest ReleaseActively TestedActively Tested
Internet Explorer 6Not CompatibleNot Compatible
Internet Explorer 7Not CompatibleNot Compatible
Internet Explorer 8Not CompatibleNot Compatible *
Internet Explorer 9CompatibleActively Tested
Internet Explorer 10CompatibleActively Tested
Internet Explorer 11CompatibleActively Tested
EdgeCompatibleCompatible
Safari 7CompatibleCompatible

* There are some known performance issues that may cause delays accessing Map View using Internet Explorer 8. Space-Time Research strongly recommends using a more recent version of Internet Explorer or an alternative modern browser where possible.

GIS and Mapping Compatibility

The SuperSTAR web products support the following mapping services:

Mapping ServiceSuperVIEWSuperWEB2
ESRI ArcIMS 9.1Not SupportedNot Supported
ESRI ArcGIS Server 9.3.xNot SupportedNot Supported
ESRI ArcGIS Server 10.0.xCompatibleCompatible
ESRI ArcGIS Server 10.1.xNot SupportedCompatible
ESRI ArcGIS Server 10.2.xNot SupportedCompatible
ESRI ArcGIS Server 10.3.xCompatibleActively Tested
Microsoft Bing Maps (in conjunction with ArcGIS Server 10)Actively TestedNot Supported
Google MapsActively TestedNot Supported

Database Compatibility

The list of databases that have been tested as part of this release are shown below.

  • All products use JDBC to connect to the database with the exception of mdcorbaserver, which uses ODBC.
  • All testing was carried out on Windows 2008 Server R2 with the exception of Teradata where a VMWare software appliance (Teradata-express-13.10.00.05) has been used.
DatabaseSuperCHANNELSuperWEB2 - UDRJob Queue ManagerMdcorbaserver
Oracle 11g R2CompatibleActively TestedActively TestedCompatible
MySQL 5.5.28Actively TestedActively TestedActively TestedCompatible
DB2 11CompatibleActively TestedActively TestedCompatible
SQL Server 2008 R2Actively TestedActively TestedCompatibleActively Tested
Teradata Express 13.10.0.05CompatibleNot SupportedNot SupportedNot Supported
H2Actively TestedNot SupportedNot SupportedNot Supported
HSQL 2.2.8Not SupportedActively TestedNot SupportedNot Supported

H2 file mode is not supported by the SuperCHANNEL GUI and can only by used with SNU (the SuperCHANNEL Command Line Utility). H2 server mode works with both the GUI and SNU. 

The drivers that have been used for testing are shown in the table below:

DatabaseSuperCHANNELSuperWEB2 - UDRJob Queue ManagerMetadata Server
Oracle 11g R2

ojdbc14.jar;orai18n.jar
(Version 10.2.0.4)

Ojdbc14.jarOjdbc14.jar11.02.00.03
MySQL 5.5.28mysql-connector-java-5.0.8-bin.jar
(Version 5.0.8)
mysql-connector-java-5.1.21-bin.jar
(Version 5.1.21)
mysql-connector-java-5.1.21-bin.jar
(Version 5.1.21)
 
DB2 11db2jcc.jar
(Version 3.63.123)

db2jcc.jar
(Version 4.16.53)

db2jcc.jar
(Version 4.16.53)

10.01.00.872
SQL Server 2008 R2

jtds-1.3.1.jar

sqljdbc4.jar

sqljdbc4.jar
(Version 4.0.2206.100)

sqljdbc4.jar
(Version 4.0.2206.100)

 
Teradata Express 13.10.0.05tdgssconfig.jar;terajdbc4.jar
(Version 14.00.00.14)
Not CompatibleNot CompatibleNot Compatible
H2h2-1.3.176.jar   
HSQL hsqldb-2.2.8.jar
(Version 2.2.8)
  

Available Ports

The default installation of SuperSERVER and SuperWEB2 require the following ports to be available. If any of these ports are not available it is possible to configure the relevant application to use other ports. Please refer to the configuration guide of the relevant product.

PortApplicationPurpose
8080Tomcat / SuperWEB2HTTP port
8009Tomcat / SuperWEB2Shutdown port
8005MDCorbaServerCORBA communications
9000SuperADMINConfiguration service
9230SuperADMINCORBA registry port
9231SuperADMINJava RMI port
9232SuperSERVERCORBA communications
9234SuperADMINJava RMI registry port

Accessibility Support

Accessibility standards exist to allow people with disabilities to be able to use websites. The World Wide Web Consortium (W3C) has published one of the most widely used guidelines for accessibility in WCAG 2.0. See http://www.w3.org for details of the Guidelines.

Space-Time Research has made good progress towards achieving WCAG Level A support.

WCAG outlines four main design principles: Perceivable, Operable, Understandable and Robust. Space-Time Research has adopted the following components of these guidelines:

  • Perceivable - the majority of the images now have alternate text.
  • Operable - most functions can be controlled using the keyboard.
  • Understandable - consistent navigation links are used through the product.
  • Robust - tested with wide range of browsers (see above for full details).

The specific components that have been converted for WCAG Level A conformance are as follows:

ProductComponents
SuperWEB2
  • Login Screen page
  • Data Catalogue page
  • TableVIEW page
SuperVIEW
  • View Selection Template
  • Configurable text for images
  • Enabled WAI-ARIA (see http://www.w3.org/WAI/) support for the main user interface library (GXT 2.2.5)

Other Support

SupportDescription
Citrix Remote Access

Citrix can be used to remote desktop to SuperCROSS. The supported version of Citrix is:

  • Client - Receiver 3.2.0.5831
  • Server - XenApp 6 Fundamentals
LDAP Support

LDAP v3 is supported for user authentication and group membership. LDAP v3 is defined by IETF RFC 4510.

Microsoft Active Directory on Windows Server 2008 is supported and actively tested.

Hardware Hypervisor Support

STR use VMware based Test Infrastructure for internal testing – ESX 4.1

The software is virtualisation-neutral and can run without modification on a virtualised server running any of our supported operating systems. The key point to keep in mind is that the SuperSTAR platform makes heavy use of CPU and disk. Providing adequate access to these resources is important for optimal performance and requires planning to achieve in a virtualised environment.

Single Sign On / KerberosSingle Sign On with Kerberos is only supported when SuperADMIN is running on Windows.
Web Security

SuperWEB2 has not gone through an independent Security Review in this release.

The last independent Security Review with penetration testing was carried out in SuperSTAR Release 7.1. Further details can be obtained by contacting Space-Time Research.

Discontinued Support

SupportDescription
SuperCROSS ChartingSuperCROSS charting functionality has been discontinued. Customers who still want to use charting in SuperCROSS will need to contact Space-Time Research.